Blocks Extensible Exchange Protocol (BEEP) Parameters
Created
- 2000-01-30
Last Updated
- 2009-06-10
Available Formats
BEEP Profiles
Registration Procedure(s)
- Expert Review
Expert(s)
- Marshall T. Rose
Reference
- RFC 3080: The Blocks Extensible Exchange Protocol Core
Note
The IANA maintains a registry of standards-track BEEP profiles (as specified in Appendix B of RFC 3080).
To add a BEEP Profile: Section 5.1 of RFC 3080 contains a registration template that should be completed, approved by the IESG, and then placed in this registry.
As a courtesy to developers of non-standards track BEEP profiles, the mailing list beepwg&lists.beepcore.org may be used to solicit commentary.
Available Formats
| Profile | Reference |
|---|---|
| http://iana.org/beep/TLS | RFC 3080 |
| http://iana.org/beep/SASL/mechanism | RFC 3080 |
| http://iana.org/beep/SYSLOG/RAW | RFC 3195 |
| http://iana.org/beep/SYSLOG/COOKED | RFC 3195 |
| http://iana.org/beep/APEX | RFC 3340 |
| http://iana.org/beep/soap | RFC 4227 |
| http://iana.org/beep/soap/1.1 | RFC 4227 |
| http://iana.org/beep/soap/1.2 | RFC 4227 |
| http://iana.org/beep/xmlrpc | RFC 3529 |
| http://iana.org/beep/TUNNEL | RFC 3620 |
| http://iana.org/beep/sacred | RFC 3767 |
| http://iana.org/beep/iris1 | RFC 3983 |
| http://iana.org/beep/iris1/dreg1 | RFC 3982 |
| http://iana.org/beep/cap/1.0 | RFC 4324 |
| http://iana.org/beep/iris1/ereg1 | RFC 4414 |
| http://iana.org/beep/netconf | RFC 4744 |
| http://iana.org/beep/iris1/dchk1 | RFC 5144 |
BEEP Features
Registration Procedure(s)
- Expert Review
Expert(s)
- Marshall T. Rose
Reference
- RFC 3080: The Blocks Extensible Exchange Protocol Core
Note
The IANA maintains a registry of standards-track BEEP features (as specified in Appendix B of RFC 3080).
To add a BEEP Feature: Section 5.2 of RFC 3080 contains a registration template that should be completed, approved by the IESG, and then placed in this registry.
As a courtesy to developers of non-standards track BEEP features, the mailing list beepwg&lists.beepcore.org may be used to solicit commentary.
Available Formats
| Feature | Reference |
|---|---|
| async | RFC 5573 |